Sign in to follow this  
Moe

Botched DirectX 9 June release update...[solved]

Recommended Posts

Hey all, A few weeks ago I decided to update to the latest release of the DirectX 9 SDK (the June update). When I installed it, it came up with an error, but continued to install. I am still experiencing some of the problems described in a previous thread. Does anyone have any idea on how to go about fixing this? I suppose I could try reinstalling the SDK and the runtimes again... [Edited by - Moe on July 1, 2005 12:22:45 PM]

Share this post


Link to post
Share on other sites
You could've at least mentioned your problems in this thread instead of redirecting people [smile]. Here they are for convenience:
Quote:
Original post by Moe
Okay, that wasn't cool. The installer gave me some error message about not being able to install the runtimes, but then continued installing everything else. Now none of the samples work! It looks like I will try re-downloading/installing it again...

"DirectX Runtime Setup failed (-9)"

Yeah, its still not working (after trying twice). That's the exact error message it's giving me. I unistalled the January 2005 SDK that I was using, then tried to install this one, and she's not working. Anyone?


Quote:
Original post by Moe
Okay, a bit of an update: When I compile the samples, they run fine. When I try to execute any of the samples out of the sample browser, they don't run (nothing comes up at all). Go figure...

Share this post


Link to post
Share on other sites
Quote:
Original post by Moe
Hey all,

A few weeks ago I decided to update to the latest release of the DirectX 9 SDK (the June update). When I installed it, it came up with an error, but continued to install. I am still experiencing some of the problems described in a previous thread. Does anyone have any idea on how to go about fixing this? I suppose I could try reinstalling the SDK and the runtimes again...


Did you send the directx.log to directx@microsoft.com as mentioned in the previous thread?

Paul

Share this post


Link to post
Share on other sites
Quote:
Original post by Moe
Yes, I did. They responded saying that they got the file.



When you extract the download, can you try specifying a unique directory (i.e. not the default, not one that already exists, etc...)? Then run the setup from that directory.

Paul

Share this post


Link to post
Share on other sites
Okay, I just tried reinstalling the SDK - still the same problem. Now when I go try to run any of the Direct3D samples, I am getting the error message:
Quote:

This application has failed to start because d3dx9_26.dll was not found. Re-installing the application may fix this problem.


Anyone? This is getting quite bothersome...

Share this post


Link to post
Share on other sites
People were having this issue with my current engine that I posted on the Your Announcements fourm. They gave me this site which ill pass on to you. http://www.toymaker.info/Games/html/directx_9_0c.html hopefully that clears things up. It gives you all the download's of the dlls, along with explaining the problem. [grin]

-edit-
I checked it seems as if he removed the dll files due to overwhelming bandwidth. I am sure you can still find them online somewhere and it does explain the problem though. Sorry for that inconvenience.

To solve this problem for me I had to uninstall all of the previous SDK's and install just the new one and then recompile my project. Maybe try that it worked for me might work for you?

Share this post


Link to post
Share on other sites
Okay, I reinstalled the SDK (again) and installed the Redistributables as well. It seems to be working fine now. Thanks for your help everyone!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this