Sign in to follow this  
gabringo

directx9sdk and visual c++ 2005 beta 2

Recommended Posts

Hello everyone, i apologize that my first post is a question. I am using visual C++ Express 2005 beta 2 and downloaded the directx9c SDK. i am new at directx, i have downloaded the sdk but when i try to compile a simple program or even the first tutorial i get the following message: fatal error C1083: Cannot open include file: 'd3d9.h': No such file or directory I tried googling the message but i got nothing. can anybody tell me if i missed something or how can i fix this isssue? [Edited by - gabringo on June 28, 2005 11:32:59 PM]

Share this post


Link to post
Share on other sites
Are you sure that the Library and Header directories were added correctly? Too add them, go to: (I only have VC2003, but this should be similar)

Tools->Options->Projects->VC++ Directories

At this point, add DXSDK_DIR\Lib\x86\ to the Library group and D3DXSDK_DIR\Include\ to the Include group. Hopefully that does it [smile]

Share this post


Link to post
Share on other sites

Thank you circlesoft, But it doesn't work, in this version when you go to:
Tools->Options->Projects->VC++ Directories
you are unable to add directories or anything else whatsoever.

I tried going to:
E:\Program Files\Microsoft Visual Studio 8\VC
adding a folder here called D3D9SDK and adding the copying the include, lib, and x86 files in it(Since this made the Platform SDK work) but it doesn't do anything i get the same error.

any other suggestions?

Share this post


Link to post
Share on other sites
Thank you Konfusius,

That is exactly where i went to get the Platform SDK running and it worked fine. My problem is getting the DirectX running. (sorry if my english is bad and that i am asking for so much help). Do i have to modify anyother files to get DirectX running?
i have been trying and trying to make it run but i get nothing...

Share this post


Link to post
Share on other sites
Create a directory inside your VC directory and call it "PlatformSDK". Copy the bin/include/lib directories from the dx sdk into the PlatformSDK directory. This should work, at least until they fix all the bugs in the express beta version.

Share this post


Link to post
Share on other sites
I did it exactly like this:

Quote:

Note: For Beta 2, you cannot set the Visual C++ Directories in the Options dialog of Visual C++ Express Edition. To work around this issue, you can update the Visual C++ Directories by modifying the VCProjectEngine.dll.express.config file located in the \vc\vcpackages subdirectory of the Visual C++ Express Edition install location. Please make sure that you also delete the file "vccomponents.dat" located in the "%USERPROFILE%\Local Settings\Application Data\Microsoft\VCExpress\8.0" if it exists before restarting Visual C++ Express Edition.


And it worked. Is it possible that you forgot adding the DXSDK paths?

Share this post


Link to post
Share on other sites
Quote:
Original post by Codemonger
Create a directory inside your VC directory and call it "PlatformSDK". Copy the bin/include/lib directories from the dx sdk into the PlatformSDK directory. This should work, at least until they fix all the bugs in the express beta version.


I'd just add them to the \vc\vcpackages\VCProjectEngine.dll.express.config paths, just like you did with the PSDK.

Share this post


Link to post
Share on other sites
Thank you guys for all your help,

I haven't had a chance to apply the changes yet since i have to go to work. As soon as i get back i will try to make it work.
Thank you all for all your help!!

Share this post


Link to post
Share on other sites
Quote:
From MS Page
For Beta 2, you cannot set the Visual C++ Directories in the Options dialog of Visual C++ Express Edition. To work around this issue, you can update the Visual C++ Directories by modifying the VCProjectEngine.dll.express.config file located in the \vc\vcpackages subdirectory of the Visual C++ Express Edition install location. Please make sure that you also delete the file "vccomponents.dat" located in the "%USERPROFILE%\Local Settings\Application Data\Microsoft\VCExpress\8.0" if it exists before restarting Visual C++ Express Edition.

That's really...stupid. Why wouldn't such simple functionality be there? Who knows.

Share this post


Link to post
Share on other sites
Thank you very much everyone!!

#include<d3dx9.h> now works
I am having other problems but i want to try to solve them by myself before posting anything
You were all very helpful!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this