Sign in to follow this  

MAXScript Question

This topic is 4543 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm trying to fix some OpenGL lighting issues in my program, and apparently I am exporting the incorrect vertex normals from max. This is what I'm using in my export script: n = getNormal tmesh face[v] This is not returning the normals I believe it should. In the MAXScript reference (which is quite baffling to say the least), it says the following: getNormal <mesh> <vert_index_integer> Returns the normal at the indexed vertex’s position as a point3. The normal is based on the faces that use the vertex and the smoothing groups assigned to those faces. Does this not mean that it should be returning the average of the face normals that the vertex shares? Because it's not. It only returns one of the face's normals. Please help.

Share this post


Link to post
Share on other sites

This topic is 4543 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this