Sign in to follow this  
3dmodelerguy

nmaespace and class problem

Recommended Posts

NOTE I HAVE VISUAL ASSIST ok here is my code:
namespace NParticleEngine
{
	class CEmitter
	{
	public:
		CEmitter();
		~CEmitter();
	};
}


namespace NParticleEngine
{
	class CParticle
	{
	public:
		CParticle();
		~CParticle();
	};
}


now when in main and i do : NParticleEngine::CParticle *p = new NParticleEngine::CParticle(); p-> i get the list of stuff in the CEmitter class but when i do: NParticleEngine::CEmitter *p = new NParticleEngine::CEmitter(); p-> all i get is the list of classes in NParticleEngine which are CEmitter and CParticle. is there anything that can be cuasing this?

Share this post


Link to post
Share on other sites
are you talking about auto complete in Visual Studio?

I had the same problem a while ago, I can't remember if VS has complete autocomplete support for namespaces. Try a complete clean/re-build see if that make a dif.

Share this post


Link to post
Share on other sites
Seeing as you have a bunch of compiler errors in the code, it is likely that Visual Assist is confused or its database is out-of-date.

Share this post


Link to post
Share on other sites
The problem is, your .ncb file is likely out of date, and because you can't build the solution, you can't bring it up to date.

If you could do a clean build successfully, your .ncb file would be brought up to date.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this