Advertisement Jump to content
Sign in to follow this  
opprobriumark

glutBitmapCharacter and textures?

This topic is 4930 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have a problem rendering text. When I try to render text using glutBitmapCharacter, nothing shows. After deleting all textures with glDeleteTextures, the glutBitmapCharacter works fine. What is going on? Here's a code snippet: //if textures are loaded, this will NOT work!? glColor4f(1.0f, 1.0f, 1.0f, 1.0f); // set foreground white glClearColor(0.0f, 0.0f, 0.0f, 1.0f); // set clear black glClear(GL_COLOR_BUFFER_BIT); // clear screen glRasterPos(40.0f, 40.0f); // set position to render text glutBitmapCharacter(GLUT_BITMAP_TIMES_ROMAN_24, 'M'); //draw text? glFlush(); // force begin processes glutSwapBuffers(); I'm in RGBA mode, alpha testing enabled, 2D textures enabled, the coordinates are valid, and this appears in a display callback function that is called constantly. Please help! Mark

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!