Jump to content
  • Advertisement
Sign in to follow this  
endether

Two questions in DirectShow

This topic is 4864 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I don't know if it is appropriate to ask this question here. It seems that many people here talk more about graphics programming, But I can't find the section for MultiMedia development. As DirectShow is part of DirectX, so there are my questions: 1: PlayWnd is a sample program in DirectShow(DirectX 9.0c SDK). I tried to compile and debuged it in MS VS.Net 2002. When I use it to open an video file, a dialog titled"Protection Error" pops up and says that: "Debuger detected - please close it down and restart!" "Windows NT users: Please note that having the WinICE/SoftIce service installed means that you are running a debugger!" when I close this dialog, the program aborted. I set many break point and found that errors occur in member function of IMediaControl ---- Run() But in fact, I've never install softwares which are like WinICE/SoftIce. Why the error ocuurs? When I run the exe file in Debug directory, no error ocuurs. And debugging in another computer, there is no error too. Why!? 2: I use VMR implement a program to play video file in Windowless mode. The program run correctly in my computer, but when it run on another compter. the DShow create a new window to display video file but not in Windowless mode. Why it create a new window??? Please help...

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
1. Do you have CloneCD, Nero and/or any other Virtual Drive Program installed?

Share this post


Link to post
Share on other sites
That's it!!
Thank you, Anonymous Poster^_^

I've installed Nero, when I check the debug output, it shows that it loads a filter from C:\Program Files\Common Files\Ahead\DSFilter, after I renamed DSFilter directory, there is no error occured. How can I stop my program loading filter from nero without changing or deleting nero's filter?
The second problem still unsolved could you give me some hints?
Thanks in advance...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!