Jump to content
  • Advertisement
Sign in to follow this  
Unreal

Pausing And Unpausing Problem With OpenAL

This topic is 4767 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello ppl! I have a problem with OpenAL.. I have a source and i pause it. Then I unpause it using alSourcePlay() but the sounds start from the beggining! why? is there any other way to unpause an OpenAL source? thanks

Share this post


Link to post
Share on other sites
Advertisement
What implementation of OpenAL are you running and on what system (Linux, Windows etc.)
What device are you initilising OpenAL with?

There is a known problem with OpenAL 1.0 on windows, if you enumerate with DirectSound3D (I think it is now called Generic Hardware rather then DirectSound3D). This will cause the source to reset itself everytime you unpause it.

Try enumerating openAL and useing another device, and see if this still occurs. If i remeber, "DirectSound" or "Generic Software" do not have this problem.

It has been a while since I worked with OpenAL, so the above advice should only be taken as a guide, rather than gospel (but then shouldn't all advice!)

Spree

Share this post


Link to post
Share on other sites
DAMN! I found new driver bug on nVidiaSoundstorm! DAMN nvidia! it cant make a driver work! I try directsound and dircesound3d but no luck. then i try the nvidia sound device and i get blue screen! damn!

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!