Jump to content
  • Advertisement
Sign in to follow this  
lem77

frames per second wrong?

This topic is 4685 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

In my app I am using a class to determine FPS ( think I stole it from GameTutorials). I´m running on a "naked" application like 75FPS. When I was using Ogre, I had FPS like 400 (naked app). Is there something wrong?

Share this post


Link to post
Share on other sites
Advertisement
Quote:
Original post by tHiSiSbOb
We'd have to see your code to say anything...


As I said, nothing special ...


void CFrameTime::Update(void)
{
m_fCurrentTime = (GLfloat)SDL_GetTicks();
m_fDeltaTime = m_fCurrentTime - m_fFrameTime;
m_fFrameTime = m_fCurrentTime;
++m_fFPSCounter;

if ( (m_fCurrentTime - m_fLastTime) > 1000.0f )
{
m_fLastTime = m_fCurrentTime;
m_fFPS = m_fFPSCounter;
m_fFPSCounter = 0.0f;
}
}



Share this post


Link to post
Share on other sites
Quote:
Original post by lem77
I´m running on a "naked" application like 75FPS.

Seems like your framerate is limited by your monitor refresh rate. You can try and disable the vertical sync via your graphics driver panel.

Share this post


Link to post
Share on other sites
thanx :) Now I understand, why Ogre uses this weird FrameListener construct ...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!