Jump to content
  • Advertisement
Sign in to follow this  
Rebuto

exporting directx shader material from 3ds max to .x not working!

This topic is 4704 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello people, I´m trying out the new directx extensions for 3ds max that come as part of the directx sdk (I´m using the june edition dx sdk and 3ds max 7 sp1). This includes a new exporter which I expected to be better than the old xskinexp.dle that used to ship with the dx sdk. The documentation for the new plugin... http://msdn.microsoft.com/library/default.asp?url=/library/en-us/directx9_c/directx/directxsdk/Tools/Content/DXExtensions/MaxPlugIn.asp ...claims that it can export directx 9 shader materials. However, I´m trying to export a cube that has one of these materials applied. Everything looks good within max, I can see the right shader being used, can tweak shader parameters and so on. However when I export the scene into a .x file I don´t get any shader data. Looking at the .x file, I can see that there are no references to a .fx file that the material should use, and I don´t get any shader parameter values either. I only get this BS: Material { 0.000000;0.000000;0.000000;0.000000;; 0.000000; 0.000000;0.000000;0.000000;; 0.000000;0.000000;0.000000;; } which is of course useless. The zeros are just the face color, specular power, etc, it´s just the standard material lighting info, nothing to do with the shader I´m actually using in the material. There are no EffectInstances defined within the material either. I don´t know if I´m doing something wrong (I don´t think so, I´ve been very careful) or if the documentation is wrong and the new plugin doesn´t export shader materials (that seems too odd). So, has anyone had any success using the new plugin to export dx shader materials from max? Thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement
I forgot to mention that the same scene will export ok using the Panda exporter. We can´t really use the panda exporter as port of our art pipeline though, due to the project spec.

Thanks again.

Share this post


Link to post
Share on other sites
I had the same problem as you. Panda fixed the problem for me...

Maybe the August SDK fixed the problem if you didn't try it already.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!