• Advertisement
Sign in to follow this  

swapped Normals

This topic is 4590 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi! After a month of hard work i finally made working x file animation code. I have only one problem. Some of normals on my mesh are swapped. Which functions are responsible for normals on mesh? Maby somebody had the same problem. Thx for answer if any.

Share this post


Link to post
Share on other sites
Advertisement
Hi there AndrewPL,
How are you doing?

[Swapped Normals?]
1) Your mesh might have been exported incorrectly. You have an option that you can invert the normals in most of the X exporters.

[Conclusion]
I hope this helps. If you have any more queries, please don't hesitate to ask

Share this post


Link to post
Share on other sites
unfortunetly it's exported correctly. In MeshViever it runs OK.
If anyone have other sugestions I would be gratefull.

Share this post


Link to post
Share on other sites
Hi Andrew,

Could you please describe to us why you are thinking it is your normals that are inverted. You could have an issue that you think is related to the normals. To better equip us to answer your question, could you please assist us by pasting a few screenshots?

Share this post


Link to post
Share on other sites
I sloved the problem. Thx for reading. If anyone is interested i mised those two functions:

d3dpp.EnableAutoDepthStencil = TRUE;

and I had:

g_pd3dDevice->Clear( 0, NULL, D3DCLEAR_TARGET, D3DCOLOR_XRGB(0,0,255), 1.0f, 0 );

insed of:

g_pd3dDevice->Clear( 0, NULL, D3DCLEAR_TARGET|D3DCLEAR_ZBUFFER, D3DCOLOR_XRGB(0,0,255), 1.0f, 0 );

I hope i'll finish work soon and show my progress in a complite source code of x-file animation

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement