Jump to content
  • Advertisement
Sign in to follow this  
Neoecs

GLUT linker errors.

This topic is 4852 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

When I'm compiling an NeHe example, using Dev-Cpp and GLUT I get alot of linker errors: [Linker error] undefined reference to `__glutInitWithExit@12' And so on, you know ;) What to do?

Share this post


Link to post
Share on other sites
Advertisement
I think I found something... I linked with libglu32.lib and then all errors gone away... But one...

C:\Documents and Settings\*\Skrivbord\ProjectX\Makefile.win [Build Error] [ProjectX.exe] Error 1

"Error 1"... That's the most descriptive error ever!?

Thanks!

[Edited by - Neoecs on April 28, 2007 9:35:43 AM]

Share this post


Link to post
Share on other sites
Sorry for tripleposting, but, I really need help with this... Thanks.

Fixed!

"To use GLUT with DevC++
1. Add the includes to the include folder.
2. Put the libs in the library folder
3. put glut32.dll in windows or windows/system or windows/system32
4. Go to compiler options add -lopengl32 -lglu32 -lglut32 to linket options
5. add #define GLUT_DISABLE_ATEXIT_HACK"

Thanks all....

[Edited by - Neoecs on August 7, 2005 6:53:02 AM]

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!