Jump to content
  • Advertisement
Sign in to follow this  
StarikKalachnikov

Milkshape .ms3d Format problem

This topic is 4846 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I'm having a problem loading the binary format of Milkshape. It's probably because i'm loading it in a slightly different way than most tutorials. The problem is that when I display the model (with texture) it looks messed up. Like the wheels are in front of the car, so i'm thinking i'm loading the uv coords wrong. When I rotate the uv texture 180 degrees and flip it horizontally, everything looks fine. Does this problem sound familiar in any way, I hope you can help me! Thanks, Starik

Share this post


Link to post
Share on other sites
Advertisement
I had the exact same problem, maybe you're loading TGA files instead of PCX? :)

but it's as simple as making two slightly different loading techniques or simply a bool to tell wheter to flip or not! :D


I'm thinking of creating my own file format.. that way copyright issues should be swept away etc... yeapp.

Share this post


Link to post
Share on other sites
I'm indeed loading the texture as a TGA file, but do you know that a TGA file is stored flipped?

I was thinking about my own file format too, but I wanted to try loading a Milkshape model first :).

Thanks alot!,

Starik

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!