Jump to content
  • Advertisement
Sign in to follow this  
ismakefire

OpenGL Missing WGL extentions

This topic is 4842 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm currently writing a graphics engine and I need it to implement several OpenGL extentions, but my problem is I'm not finding them in 'glGetString()' or 'wglGetExtensionsStringARB()'. I read that some WGL extensions should show up in both, but I'm only gettting WGL_EXT_extensions_string and WGL_EXT_swap_control from 'glGetString()' and 'wglGetExtensionsStringARB()' si returning null. The only thing I can think of is that ATI might suck and not support OpenGL 1.5, but I could be wrong. What could I be doing wrong? -I downloaded my latest drivers as of 10 minutes with no change -I use an ATI RADEON 9600 and windows XP -Currently I'd like to use these extensions: WGL_ARB_render_texture, WGL_ARB_pbuffer, WGL_ARB_pixel_format and WGL_ARB_make_current_read.

Share this post


Link to post
Share on other sites
Advertisement
AH HA! It was a matter of ARBs and EXTs!

What I had:
WGL_EXT_extensions_string

Which alows for:
const char* wglGetExtensionsStringEXT();

When all along I was tring to use:
const char* wglGetExtensionsStringARB(HDC hdc);



I guess a days worth of reading random docs, opengl.org and ATIs specs paid off...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!