Jump to content
  • Advertisement
Sign in to follow this  
Simian Man

SDL fullscreen and lack of cursor

This topic is 4841 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

When I make a fullscreen SDL app, the cursor disappears (even if I call SDL_WM_ShowCursor). Is there anything I can do (or am doing wrong) that can fix this? I guess I could just implement my own but that seems unnecessary. The funny thing is if I make a fullscreen SDL/OpenGL app, the cursor remains. Any thoughts?

Share this post


Link to post
Share on other sites
Advertisement
Hey Simian!

Dont quote me on this, as this is my first stab back at SDL in about 2.3months. If you give me time to get home and look this up in my engine, I'll give ya a for sure answer.

I think there was a method in SDL other than the initializer that you spoke of that did the same thing.

SDL_ShowCursor(bool)

So, I believe you can throw that 1 or 0 in and it may do it... I don't know try it out. Like I said, if noone posts before I get home I'll give you the for sure answer, because in TRUform, I know I can choose mid-runtime to show or hide the cursor.

EDIT: Just looked it up on the net and found this!

WOW! I was right for once [smile]


Hope this helps!

toXic1337

Share this post


Link to post
Share on other sites
This is actually an error, and is discussed in the SDL FAQ. It turns out that your graphics card can't support having the cursor (or something like this). To fix it, simply turn the cursor off using whatever functions, and then have a sprite where ever the cursor would be. I'll try to find the link.

Edit: I'm so good:

http://www.libsdl.org/faq.php?action=listentries&category=2#83

Share this post


Link to post
Share on other sites
Thanks guys. I actually am having a lot of problems with SDL in fullscreen mode. When my app tries to free surfaces, I get a segmentation fault - even though they blit fine! And one thing I'm drawing appears fine in windowed mode but is not drawn at all in fullscreen.

I think it may be driver trouble - the card I have is deprecated and I can't change it because it's integrated with the motherboard (laptop).

Share this post


Link to post
Share on other sites
Make sure you have the latest SDL.dll.

I remember I had all these weird problems and then I downloaded the newest version and most of them got sorted out.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!