Jump to content
  • Advertisement
Sign in to follow this  
cow_in_the_well

ARGH! The debugger is killing me here!!

This topic is 4838 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Uhm, hi. I just had a somewhat successful day playing with SWIG to expose my legacy C++ code to C#. I can now use my engine (implemented in C++) from C#. Now, I find that it won't let me step into the unmanaged C++ code from the managed code (interfaced via PInvoke), so I go through the project options for the C# application and see "Enable Unmanaged Debugging". Hooray! So I turn this on, and 'lo! it worked....with one snag: it now sits there doing apparently _NOTHING_ (no cpu usage or HDD usage) for 15-20 seconds before it starts executing. It also has made stepping through the code increadibly sluggish :(. Any clues on what I need to do? Perhaps I need to upgrade to VS2005 beta? (this could work, but apparently I can't use the beta .NET platform for 4e4 -_-). Oh yeah, I'm currently using MSVS2003. Thank you very muchly.

Share this post


Link to post
Share on other sites
Advertisement
Just thought I'd mention, in case anyone is interested, that I received the VS2005 beta 2 in the post today, and it's support for mixed mode debugging is superb. No noticiable slow down at all :D.

The deprecation of stuff like fopen is a tad annoying tho :/. Oh well, until 2005 final is release I've disabled that warning :P.

kthxbie.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!