Jump to content
  • Advertisement
Sign in to follow this  
Tang of the Mountain

OpenGL OpenGL: The Reversal of UV's

This topic is 4841 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Ok..lemme lay it down for ya. *grin* Im working on a game that uses OpenGL for the renderer and devIL for the image loading. I Set up a single quad to cover the screen for a background image(Title screen). The quad is drawing from top left, counter clockwise. and the uv's the same in perfect order. The image I loaded is flipped upside down. While normally one would say, "Duh, flip your UV's" followed by calling me a tool or something. However, I am a member of a six man group. All of whom use the exact same laptop to program on. The other 5, when running the exact same code(We are using source control(ALienbrain) so we have the same build.) they see the image as it should be. "What is that you say?!" I have spoken personally with Richard Wright, Author of the OpenGL superbible, and he cant even begin to fathom what the problem is. Every model I load in the game, the textures are totally screwed. And i am the only one who has this problem. Like i said same IDE, same computer, same drivers, same everything. Same code, same projects. There has to be some difference obviously. My thoughts were that either devIL is for some reason flipping images on my laptop only. Which is kinda out there. or my texture unit is totally blitzed and is passing information backwards. Any ideas? Im not loking for a solution per se. But toss some ideas at me, short of building one version for me ith flipped uvs and one for everyone else, i got nothin. Ive spoken with 3 seasoned pros who are all stumped. Even if it seems rediculous, lemme know and Ill try it. By the way, i have installed new omega drivers and i have the same problem. thanks again.

Share this post


Link to post
Share on other sites
Advertisement
I've had problems with DevIL loading images in flipped around. I fixed by using the ilOriginFunc function passing in IL_ORIGIN_UPPER_LEFT. It basically tells DevIL to flip images round if they need it so it all loads the correct way up.

Share this post


Link to post
Share on other sites
It seemed to have worked. I had to use IL_ORIGIN_UPPER_LEFT in stead, however, since I am at my hoem now, My team wont be able to check it till the AM so we'll see. Thanks for the info, Ill reply again if it seems to have been an illusion. Thanks a great deal for your info.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!