Jump to content
  • Advertisement
Sign in to follow this  
orcfan32

Dev-C++: Makefile Error

This topic is 4844 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement
Try to delete the Makefile if it exists (Makefile.win or something similar in your project dir) perhaps it somehow became write-only. If that doesn't help try deleting all non-project files and attempting a build from there, if it still fails ask on the Dev-C++ forums.

Share this post


Link to post
Share on other sites
Quote:
Original post by orcfan32
How did you know that, Gor435?


Simple I am a genius. [smile]

No really I had it happen to me also and I know how to fix it.

I will post a description on how to fix it in a min need to go over my process and make sure I can explain it properly.

Share this post


Link to post
Share on other sites
Note: Your file names and such my not be the same it depends on where you installed dev-c++

First open your compiler.
Next click on the tools option.
Then choose Compiler Options.

Now you will see tabs at the top of the compiler options window.
Click directories.
You will see a new set of tabs.

In the binaries tab you need to get delete the line that says C:\Dev-Cpp\lib\gcc-lib\mingw32\3.3.1

and replace it with
C:\Dev-Cpp\libexec\gcc\mingw32\3.4.2

next you will want to go to the C++ includes tab.
replace all 3.3.1 includes with the same 3.4.2 includes

now you my close your compiler

find and open your bin folder
mine is C:\Dev-Cpp\bin

add something (like .bla thats what I did lol)
to the end of the file mingw32-gcc-3.3.1
or you can delete it I say add something just to change it so if it dosn't work you can just change it back.

I know you probably are wondering how I figured all this out. Trust me I pulled my hair out trying to get my compiler to work right again.

Now open up your compiler and start a new project and try it out. [smile]

Share this post


Link to post
Share on other sites
Quote:
Original post by orcfan32
Don't waste your time there, it's fixed now, all I had to do was delete the makefile.


Ok but if that was your problem it will happen every time you start a project

My description is assuming you installed the 3.4.2 mingw upgrade.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!