Jump to content
  • Advertisement
Sign in to follow this  
Eleventy

Sound only works after restarting sound system with YaST under SuSE

This topic is 4837 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

After installing SuSE 9.3, I realized that I had left my onboard sound card enabled in the BIOS. When I booted up Linux, it was using the onboard sound card as the default (other than my Sound Blaster Live). After deleting the entry for the onboard sound card and saving the config in YaST, every time I boot my computer, I get no sound at all. If I run KMix, it'll show the onboard sound card (which I deleted) and some unknown USB sound device (which I don't have). Now, if I go into the sound card hardware module under YaST, click the "Change..." button near the bottom of the window (those of you who have SuSE 9.3 will know what I'm talking about), I'll then be greeted with a message saying that the number of sound cards running doesn't match the number configured. It'll then restart the sound system and everything will work fine. KMix also shows the correct Sound Blaster Live sound card (with no others). However, I have to do this every time that I reboot the computer. I've tried restarting the sound system using the command line, but I believe YaST does something special for the sound system to be restarted "properly". Does anyone have any suggestions on how to fix this?

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!