Jump to content
  • Advertisement
Sign in to follow this  
chuchu_leon

CG ERROR : An unsupported GL extension was required

This topic is 4838 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi everybody, I run a display routine with a vertex shader with Cg in OpenGL, the first time through (first frame of the display) it runs well (although the CPU part takes way too long, but that's another issue). The second frame, when I call cgGLBindProgram(v_thesis_prog); CheckCgError(); The program detects and prints the following error on the console: CG ERROR : An unsupported GL extension was required to perform this operation. I've been basing my code to tie in with the shader on Cg samples that don't require GL extensions and that run well in my computer, and I've included everything I've seen they include in these programs. Any suggestions or comments would be greatly appreciated. Thank you in advance.

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!