Jump to content
  • Advertisement
Sign in to follow this  
Antrim

[.net] Unhandled exception , User breakpoint, how?

This topic is 4836 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So after lots and lots of debugging on other code, I all of a sudden notice that I'm getting new "Unhandled exception at 0x7c901230 in Test.exe: User breakpoint." I had my "shutdown" key for my Engine set to F12. And anytime I hit "F12" when I was debugging, I got that error. After a few times, and not having any idea where this error could have come from, I figured out that it wasn't a problem with my code. I moved my "shutdown" function to F11, and had absolutly nothing assigned to F12. At this point, if I ran the exe file itself, pressing F12 did nothing as expected. However, when running the debugger hitting F12 still gives me this error. I can only assume that I somehow unknowingly told VS.NET to use F12 as a breakpoint. If this is what is going on, does anyone have any idea how to remove this debugging functionality from the F12 key? If this is actually a sign of a larger problem, I'd appreciate any info on what it might be. Thanks for any input.

Share this post


Link to post
Share on other sites
Advertisement
According to the tools->options->environment->keyboard list F12 is used as global shortcut. I guess that means during debugging as well.

Share this post


Link to post
Share on other sites
Yeah, I see the shortcut listed there, but it is for "Edit.GoToDefinition" for all the possible environments under that tab. I still can't figure out how it is causing a user breakpoint.

I just tested it with other, similar programs from other people, and it does the same thing when I hit F12 in those programs when debugging. So it must be a global issue, I just can't seem to find it.

Share this post


Link to post
Share on other sites
Ok, solved (kind of) my own problem.

After some googling, I found a thread with a similar problem, and the answer pointed here:

MS Support

<cheer> F12 injecting a breakpoint is a *feature* that can't be disabled.

Kind of annoying, but at least now I know it wasn't something I did. I'm just baffled that I never got this error before.

Share this post


Link to post
Share on other sites
To should be able to disable the shortcut if you go to Tools->Customize->Keyboard->"Edit.GoToDefinition"->Remove

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!