Jump to content
  • Advertisement
Sign in to follow this  
MTclip

switching from debug to release..??

This topic is 4832 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

for my project i always compiled uising debug... when i switch to release it produces several debug errors ..... involving unrelved external symbols what gives... and what exactly is the difference between the two... thanks ;P

Share this post


Link to post
Share on other sites
Advertisement
I'm guessing that in your project settings, you have some header or library files included, and these files are missing from your release build. Check the project settings for release and make sure they're the same.

While you're in project settings, you can look there and see exactly what the differences are. They're just two different sets of build settings. The big difference is that in Debug, the compiler includes lots of extra debugging information in your app, which makes it run slower but allows you to step through the code.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!