Sign in to follow this  
D3DXVECTOR3

Strange artifacts (with images)

Recommended Posts

When an mesh is far some parts are missing (in a jigsaw pattern) but when I get closer to the object the jigsaw flattens/dissapears and the mesh looks oke. I dont know how to describe this, check the screens: ScreenShot001 ScreenShot002 What could be the reason for this strange effect?

Share this post


Link to post
Share on other sites
First guess would be: z-fighting.
If only it wasn't so close to the viewer...
What are your zmin and zmax?
~def

Share this post


Link to post
Share on other sites
yep, same as Deffer, it seems to be a problem of z-fighting
make sure you doesn't have a very close near clip and a very far away far clip (for example, 0.0001 and 1000000.0 are really bad values ^^)

Share this post


Link to post
Share on other sites
These are my values:
nearPlane = 0.1f;
farPlane = 10240.0f;

Im using the same units as UT2003/2004. before that I uses a smaller unit scale.

edit:
I changes the nearPlane to 1.0f and it looks like that have dissapeared :D
well almost, in the 2nd pic you see the a vent that one isnt good yet. What values should I be using!?

Share this post


Link to post
Share on other sites
You values are pretty much ok (but I would stick with 1.0 instead of 0.1).

How do you render the vent? Is it a full mesh, or a bilboard, or projection of some kind? (can't see well on the pictures).
~def

Share this post


Link to post
Share on other sites
Its a full mesh. I have now set the nearPlane to 4.0f. because the 1.0f has still some z-fighting

I think that the 64 units in UT2003/2004 is about 1 meter. I dont hope that 4.0f will have issues with other things.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this