• Advertisement
Sign in to follow this  

Lightmap + base texture problem

This topic is 4521 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi everyone. I have implemented a lightmapper and I face the following problem : The dark areas of the lightmaps (the ones which receive no light and are set to the ambient light intensity), when combined with the base texture, produce a final result which is too dark to see. I have tried setting the ambient light intensity to a very high value (140, 140, 140) which appears as bright grey on the bare lightmaps but the result is still too dark. Do you have any suggestions as to what I am doing wrong? I am using the OpenGL API. Thanks.

Share this post


Link to post
Share on other sites
Advertisement
Sounds like your shadowmap is too dark. Brighten it up a bit.

Share this post


Link to post
Share on other sites
um... this kind of reminds me of texture splatting. When your blending factors dont add up to one, you get very dark terrain (where this is a common application where texture splatting is performed). There is a texture splatting article on gamedev, and this is briefly mentioned.

Share this post


Link to post
Share on other sites
Are you sure that the light map and the base color map are the only things affecting the output data? You have turned off GL_LIGHTING? The first texture env mode is REPLACE and the second is MODULATE?

When used with light mapping, the color maps should typically be full-bright, which (inside Photoshop) will look WAY too bright. Make sure you brighten your color maps as much as possible.

Another thing you can try is something like a MODULATE2X blend mode; there's some extensions that let you do that.

Share this post


Link to post
Share on other sites
Quote:
Original post by hplus0603
Are you sure that the light map and the base color map are the only things affecting the output data? You have turned off GL_LIGHTING? The first texture env mode is REPLACE and the second is MODULATE?

When used with light mapping, the color maps should typically be full-bright, which (inside Photoshop) will look WAY too bright. Make sure you brighten your color maps as much as possible.

Another thing you can try is something like a MODULATE2X blend mode; there's some extensions that let you do that.


What do you mean by "first" and "second" texture? Are you referring to the textures in the GL_TEXTURE0_ARB and GL_TEXTURE1_ARB channels?

Secondly, what do you mean by color maps?

Thanks for your input so far!

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement