Sign in to follow this  
GreenGiant

dx8 tutorial problem

Recommended Posts

Lo peeps, I'm giving a tutorial i found on dx8 a go, but having some problems. Now I know this should be in the newbie section, but since it's dx specific, thought i might as well post it here :) Ok, so the site is: http://www.andypike.com/tutorials/directx8/001.asp Now the annoying but is right at the beginning, where the guys says: 2. Make sure that your project settings are correct. a. Project > Settings... b. On the Link tab, make sure that "d3d8.lib" is in the list of Object/Library Modules. If it isn’t simply type it in. AND 3. Make sure that your search paths are correct. a. Tools > Options > Directories Tab b. In the "Show directories for" drop-down, select "include files". c. If it does not exist already, add the following path: <SDK INSTALL PATH>\include. d. Make sure that this path is at the top of the list by clicking on the up arrow button (if needed). e. In the "Show directories for" drop-down, select "library files". f. If it does not exist already, add the following path: <SDK INSTALL PATH>\lib. g. Make sure that this path is at the top of the list by clicking on the up arrow button (if needed). Now in my version of VS C++, the things he said (Project > Settings, Tools > Options > Directories Tab) do not exist! I've been scratching my brain on where it could be, but whatever I do it doesn't seem to work as when I compile the source he gave I always get an error. Has this happened before to anybody? Know a way around it? Thanks a lot! -greengiant

Share this post


Link to post
Share on other sites
The instructions you gived out is about MS Visual C++6.0
In .net, it should be project->attribute->linker->input->additional dependencies
AND
tool->option->project->vc++ directories
hope it will be helpful

Share this post


Link to post
Share on other sites
Quote:
Original post by Konfusius
Try Extras/Options, Projects, VC++-Directories.

Don't know if that is the exact wording, because I am using a german version of C++.


Yeah those are some of ones I tried, while looking for the settings the bloke was talking about in the tutorial. They weren't right...

Share this post


Link to post
Share on other sites
Quote:
Original post by ANuy
The instructions you gived out is about MS Visual C++6.0
In .net, it should be project->attribute->linker->input->additional dependencies
AND
tool->option->project->vc++ directories
hope it will be helpful


Ahh, I'll give that a go now.

Share this post


Link to post
Share on other sites
Quote:
Original post by ANuy
The instructions you gived out is about MS Visual C++6.0


Actually they are about german Visual C++ 2003, translittered into english. [wink]

Share this post


Link to post
Share on other sites
Ok so I gave it a go, and re-compiled but I got the same error as before.

In tutorial it said:
On the Link tab, make sure that "d3d8.lib" is in the list of Object/Library Modules

I did:
http://img148.imageshack.us/img148/9504/lib7rx.jpg

In tutorial it said:
If it does not exist already, add the following path: <SDK INSTALL PATH>\include.
If it does not exist already, add the following path: <SDK INSTALL PATH>\lib.

I did:
http://img148.imageshack.us/img148/2518/directory4lj.jpg

And get this error from his code:

Direct X.cpp(165): fatal error C1010: unexpected end of file while looking for precompiled header directive.

Share this post


Link to post
Share on other sites
That is the .NET SDK path.
Your DirectX SDK is probably in a location like C:\Program Files\Microsoft DirectX 9.0 SDK (August 2005).
Also, you added them to the "Executable files".
Add the .lib dir to "Library files" (or whatever it is called) and the inc dir to the "Include files".
As for the error: add #include "stdafx.h" at the top of each .cpp file.

Share this post


Link to post
Share on other sites
Quote:
Original post by Konfusius
That is the .NET SDK path.
Your DirectX SDK is probably in a location like C:\Program Files\Microsoft
DirectX 9.0 SDK (August 2005).


Hmm, I don't have that folder. Nevermind though, it worked. Thanks for all the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this