Jump to content
  • Advertisement
Sign in to follow this  
Ademan555

[web] ftp and router

This topic is 4814 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So i have my ftp server up, and I'm able to connect to it locally (through other computers on the same network, with its local ip address) but im unable to connect through its wan ip, i have ports 21 and 20 forwarded to the server as well as ports 1025 - 3000 the connection seems to work to some degree, it tries to go into PASV mode, then the connection times out. heres the log:
    SmartFTP v1.5.988.47
    Resolving host name "***************"
    Connecting to ***.***.***.*** Port: 21
    Connected to **********************.
220-Cerberus FTP Server Personal Edition
220-UNREGISTERED
220-Welcome to Cerberus FTP Server
220-Created by Grant Averett
220 MUUUUNNNGGGG!!!
    USER mung
331 User mung, password please
    PASS (hidden)
230 Password Ok, User logged in
    SYST
215 UNIX Type: L8
    FEAT
211- Additional features supported include:
211- MDTM
211- SIZE
211- REST STREAM
211- UTF8
211- LANG EN*
211- SITE CHMOD
211- SITE PSWD
211 
    TYPE I
200 Type Binary
    REST 0
350 Restarting at byte offset 0. Send STOR or RETR to initiate transfer
    PWD
257 "/" is the current directory
    PASV
    Timeout (20s).
    Active Help: http://www.smartftp.com/support/kb/index.php/45
    Client closed the connection.
    Automatic failover of data connection mode from "Passive Mode (PASV)" to "Active Mode (PORT)".


Does anyone have any clue what might be causing this?

Share this post


Link to post
Share on other sites
Advertisement
Have you tried forcing your client into active mode? If that's not possible, grab another client which can be set like so. I have seen similar problems with some FTP servers I used in the past. Switching from active to passive usually resolved these issues.

Share this post


Link to post
Share on other sites
In PASV mode the server opens a TCP socket and the client tries to connect to that. ACTIVE mode is the same but now the client opens a socket.
Make sure both client and server firewalls do not block these connections.

Share this post


Link to post
Share on other sites
Ensure that the local ports your FTP server chooses are in a range that you've forwarded from your router. Any decent FTP server has a configuration option that lets you choose the local port number range for passive FTP data connections.

This should enable passive FTP to work.

For active FTP to work, the FTP server needs to be able to make outgoing connections; active FTP is not recommended, and many clients use passive by default (some even support *only* passive)

Mark

Share this post


Link to post
Share on other sites
Hrm, well my ftp server's pasv port range matches the range forwarded from my router, but still no luck, i wonder if it has something to do with using dyndns... i dont know

cheers
-Dan

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!