Jump to content
  • Advertisement
Sign in to follow this  
paulbird

unresolved issue

This topic is 4830 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I keep getting error message this: link error: unresolved external 'glBindTexture' in my OpenGL program. But I have the file opengl32.dll in the windows/sytem folder which i checked has a reference to glBindTexture in it. So surely i shouldn't get this message should I? The openGL 1.0 functions all work fine. could someone who knows more about libraries and linking and stuff than me explain what's going on here? or maybe suggest somethings i could try out?

Share this post


Link to post
Share on other sites
Advertisement
Seems to me like your forgetting to link in a required library. What compilier are you using? GCC or VC? command line, make files, or IDE?

Linking static and dynamic should be covered in the library docs somewhere, if it's command line compile then it is most likely something such as

gcc <normal options> -lopengl32 (or something similier)

if it's IDE, then you'll have to wade through some menu's to get to where you input that (and its different in different versions of VS slightly)

Share this post


Link to post
Share on other sites
i am using bcc32 (borland C++ 4.50)

i didn't link to the library since all the other openGL commands work fine except the new ones from version 2.0 i think. maybe i should link? does anyone know how to do that?

i don't know why it is only glBindTexture that it can't find.

Share this post


Link to post
Share on other sites
Hooray hooray hooray!

I've done it at last. Here is what to do if anyone else needs to do it:

Borland 4.5 doesn't support opengl1.1 out of the box so you must:

1) download opengl95.exe
2) put all the files in the right places
3) use command line to change DLL to Borland compatible lib:
> implib mygl.lib opengl.dll
4) link the library in your CPP file by adding
#pragma comment(lib,"c:/bc45/mygl.lib")

what a palava!!! well at least it works now and i can make proper programs with textures using glBindTexture!!!

Woohoo!! :o)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!