Jump to content
  • Advertisement
Sign in to follow this  
viperld

newb problem

This topic is 4741 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

i've been just learning the basics of game programming with DirectX, im using VC6(plus plus). Im learning from -Beginning game Programming, by Jonathan S. Harbour-. If any one else has it, im on chp.7. i'm trying to get a sprite to run across a bitmap'd scene. From left, to right, repeating. Upon my first completion there were many errors, as usual. I corrected all but 3 of them. Next i cross checked/compaired my code to the CD-Resource code from the book. The executable on the CD runs perfectly. And after correcting it to match the resource code, mine still doesnt work. It shows no errors, but upon executing nothing comes up. I thought it may be the winmain.cpp, not creating a window, but its looks fine. Im stumped. Not by any means angered or annoyed, but stummped, and i need some help with why it doesnt execute. O yea, and my programming skills are basic. I've learned fast, but this is still the beginning for me. Can anyone please help me? I can email the project if your intrested in looking at it.

Share this post


Link to post
Share on other sites
Advertisement
you should post some cod but you are most likely not swapping buffers so everything keeps being rendered to the backbuffer without being pushed to the screen. Cant really help too much without some code so feel free to post some(prolly not all fo it)

Share this post


Link to post
Share on other sites
thats the thing-i really cant tell what could be wrong with it.
So i dont kno what to specificly post.
But i can tell you the files so you can tell me what to post.
winmain.cpp
game.cpp
dxgraphics.cpp
game.h
dxgraphics.h

i think the buffering is fine.
once again, im really sry for not really knowing what the problem is.
i'd still like you to help me if u can.
i can mail u the project or files. the projects 8 MB.

Share this post


Link to post
Share on other sites
Quote:
It shows no errors, but upon executing nothing comes up. I thought it may be the winmain.cpp, not creating a window, but its looks fine.

Are you saying it's not even showing a window?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!