Jump to content
  • Advertisement
Sign in to follow this  
Trillian

simple CreateDevice problem

This topic is 4810 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello! I have what I hope to be a small and simple problem: Each of my calls to CreateDevice() makes an error while debugging: Direct3D9: (INFO) :Failed to create driver indexbuffer Thats my call: pD3D->CreateDevice( D3DADAPTER_DEFAULT, D3DDEVTYPE_HAL, hWnd, D3DCREATE_HARDWARE_VERTEXPROCESSING, &d3dpp, &pD3DDevice ) Thats my d3dpp: D3DPRESENT_PARAMETERS d3dpp= { width, height, D3DFMT_X8R8G8B8, 1, D3DMULTISAMPLE_NONMASKABLE, (D3DMULTISAMPLE_TYPE)(QualityLevel-1), D3DSWAPEFFECT_DISCARD, hWnd, !bFullscreen, TRUE, D3DFMT_D24S8, 0, D3DPRESENT_RATE_DEFAULT, D3DPRESENT_INTERVAL_DEFAULT }; Thats my system: System: Intel Pentium 4 CPU 3.00GHz (2CPUs), ~3.00GHz Microsoft windows XP home edition 512MB RAM ATI RADEON 9200 DirectX 9.0c(DXSDK august 2005) Now this isn't a real problem because everything works really fine but I'm still annoyed by it. Thanks

Share this post


Link to post
Share on other sites
Advertisement
Don't worry, this isn't a problem with your app. All it means is that your graphics card doesn't support index buffers in graphics card memory. I have yet to see a graphics card/driver set that doesn't yield this message - perhaps the newer ATI's and NV's do, though.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!