Jump to content
  • Advertisement
Sign in to follow this  
Tanczos

CDS_FULLSCREEN

This topic is 4623 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Yes, I'm stuck on the first tutorial! My Dev C++ 4 says that CDS_FULLSCREEN is an undeclared identifier. It has no trouble with the header files, so I would have thought it was some spelling error. But I checked the tutorial code and the Borland code, and the spelling is the same. Any solution? This is very frustrating . . .

Share this post


Link to post
Share on other sites
Advertisement
it's not in the headers for some reason. but IIRC, use this..

#ifndef CDS_FULLSCREEN
#define CDS_FULLSCREEN 4
#endif

Share this post


Link to post
Share on other sites
Thanks! Now it compiles, but the Compiler and Linker Output window raves on about undefined references to glShadeModel@4 and the like.
I'm obviously out of my depth here. Is there any textbooks for beginners in Dev C++?

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
You need to add the opengl link libraries.

Share this post


Link to post
Share on other sites
Quote:
Original post by Anonymous Poster
You need to add the opengl link libraries.


Thanks . . . You mean add them to my project, or add them to Dev C++? I tried to sort all this out a while ago with the Borland C++ compiler, but it was quite beyond me then.

Share this post


Link to post
Share on other sites
i haven't used dev-c++ in a long time, but in the linker options(somewhere) you have to link the proper libraries, such as opengl32.lib glu32.lib...

edit:

Dev-C++ FAQ

Quote:

9. How can i use the OpenGL library and others ?

All the libraries that comes with Mingw reside in the Lib directory. They are all named in the following way: lib*.a
To link a library with your project, just add in Project options, Further option files :
-lopengl32
This is for including the libopengl32.a library. To add any other library, just follow the same syntax:
Type -l (L in lowercase) plus the base name of the library (filename without "lib" and the ".a" extension).

Share this post


Link to post
Share on other sites
For some reason the project menu is greyed out, and the project options button doesn't do anything. Am I missing something?

Share this post


Link to post
Share on other sites
Quote:
Original post by PinguinDude
You need gdi32.a linked to your project.


This was the file I was missing. It runs fine now, thanks. For some reason if I open the project from NeHe I can't open the Project menus. I can cut and paste it into a new project though. Wierd . . . oh well, I guess I'll figure that one out one day.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!