Sign in to follow this  
Krulwick

.DDS Texture Alpha Channel displays incorrectly in 3DS MAX

Recommended Posts

Hi, I am hoping someone can help me with this. I have successfully created a .DDS texture in Photohsop with an Aplha Channel. I used the DDS plugin from Nvidia. I load my texture in the Max material editor, placing it in the Diifuse slot and Opacity slot, but the image's opacity areas do not show up correctly in my viewport or any renders. The Alpha does seem to be working because the areas that should be transparent are indeed, transparent. However, the diffuse area which is the actual image or texture also is transparent and not opaque as it should be. I have saved the .DDS texture to every appropriate format used by the Photoshop plugin and I have tried all settings in the material editor's diffuse and opacity slots but nothing changes. If I use a TGA image in the Max material editor with an Alpha channel, it works just fine. I am at a loss to figure this out and this project has to have a .DDS texture with an alpha. Thanks in advance for any help someone may be able to give. KRULWICK

Share this post


Link to post
Share on other sites
i don't really use .dds textures too much in max, the only thing i can think of is that you aren't choosing the right alpha type when saving your .dds files. its been a while but i believe dxt2-dxt5 are all different types of alpha, you should experiement with these.

Share this post


Link to post
Share on other sites
Thank you Jarrod, for your reply.

I have tried every .DDS format the plugin uses to retain an Alpha Channel and I have experimented with all settings in the Material Editor, but the transparency is seen everywhere on the texture and not just where it is supposed to be.

I thought it might be a video card issue as I have an older card (Voodoo 3) but I am not having any other problems with the texture.

KRULWICK

Share this post


Link to post
Share on other sites
well i'm not too sure, you may be doing the transparency wrong in 3ds max or you need to get the .dds plugin for 3ds max off of nvidia.com.
why are you wanting to use .dds anyway? just get a batch converter and convert them all to .tga or .png.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this