Sign in to follow this  
xtal

OpenGL Tesselation artifacting : help needed

Recommended Posts

I'm implementing a tesselated cube that I will be cutting up in various ways. Tesselation works great, however, I have an unexplained visual artifact that has me completely stumped. At higher division levels, I get a triangle-shaped artifact that appears on the face. This artifact becomes more and more localized as the division level increases. I have attached the following screenshots with all vertex normals drawn. My first intuition was the face normal was incorrect, but this does not appear to be the case. ANY advice is helpful. I'm completely stumped. Division 3 : http://www.nyx.net/~smanley/opengl.jpg Same model, Division 6: http://www.nyx.net/~smanley/opengl2.jpg Inside the box: http://www.nyx.net/~smanley/opengl3.jpg http://www.nyx.net/~smanley/opengl4.jpg Has anyone seen anything like this before? Thanks, Steve

Share this post


Link to post
Share on other sites
I agree with you 100%, however, the normals at each vertex are as drawn - e.g, apparently correct.

Hence my confusion. I don't disagree that it is the obvious cause, but I'm wondering if there are any possibilities, as I have pounded on this for awhile, and the normals appear to be correct.

Share this post


Link to post
Share on other sites
Will check on the memory situation, that is possible, but I'd expect the vertex normal representation on the line to be flawed then as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this