Sign in to follow this  

keyb.asm - compiles but then shwos up as unrec...

This topic is 4416 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Here's my problem. I can compile the .asm file (keyb.asm) fine without errors (using nasm -f coff keyb.asm -o keyb.o), but then when I use it in the linker (using ld ...) itworks fine until it hits that file and gives me this error: root@1[OS]# gcc -Wl,--section-start,.text=0x0 -ffreestanding -nostdlib main.c video.c ports.c ints.c keyb.o -o kernel.elf keyb.o: file not recognized: File format not recognized collect2: ld returned 1 exit status Any ideas? Thanks in advance. NOTE: I've also tried this way and got the same error message: root@1[OS]# ld -e _start -Ttext 0x0 -o kernel.o main.o video.o ports.o keyb.o ints.o keyb.o: file not recognized: File format not recognized

Share this post


Link to post
Share on other sites

This topic is 4416 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this