Jump to content
  • Advertisement
Sign in to follow this  
C plus noob

VC++ Class Thing not working (Intellisence Prob)

This topic is 4630 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

im using VC++ 2003 .NET PRO when i was programming say when i used WNDCLASSEX wc; when i went wc. right after the . a menu would pop up with the attributes of the struct/class in which you could double click it to add it to your source. now it doesnt work, any idea on how to re-enable this? [Edited by - C plus noob on November 12, 2005 9:21:32 PM]

Share this post


Link to post
Share on other sites
Advertisement
That's called Intellisense. You can check your options to see if you turned it off, but in all likelyhood it's either being slow, or the intellisense database was corrupted. Go into your solution directory and delete <solutionname>.ncb then go back to visual studio and let it rebuild the database. This usually wakes up intellisense for me.

Share this post


Link to post
Share on other sites
thanks, how to i let it rebuild sumthing or whatever, i think its corrupted as not long agothe program crashed trying to make an icon resource... i need it because i have a struct with close to 50 attributes, i just need reminding of what they are without having to look back XD

Share this post


Link to post
Share on other sites
Microsoft says that you close the solution, delete the ncb, then open the solution. It will automatically rebuild it you just have to wait a few minutes (it does it in the background though, just look at the ncb and when it's file size stops changing it's done)

The link also provides links to how to change intellisense options.

Share this post


Link to post
Share on other sites
i appreciate it, im a VC++ noob, i recently switched from Dev Cpp; would you have any idea why it crashed when i tried to create an icon resource?

Share this post


Link to post
Share on other sites
Quote:

To turn IntelliSense options off by default

1. On the Tools menu, click Options.
2. Select the Text Editor folder.
3. Select the folder for the language you want to customize IntelliSense.
4. Select a property page for the language and clear check boxes for the options that you do not want.

To change default key mappings for IntelliSense options

1. On the Tools menu, click Options.
2. Click the Environment folder and then click the Keyboard page.
3. In the list box, click one of the following:
* Edit.ListMembers
* Edit.ParameterInfo
* Edit.QuickInfo
* Edit.CompleteWord

qhat am i looking for

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!