Jump to content
  • Advertisement
Sign in to follow this  
iannan

A display problem (display a .x file)

This topic is 4867 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi all When I display a .x model, it occurs a problem. This link is the screen shot: http://photo.xuite.net/iannan/368597/1.jpg I marked my problem with red rectangles. 1.the door: I modeled a yellow wall first, then added an iron door texture on the wall. But now we can see the yellow wall, too. That's not what I expect. 2.the desk: the problem of the desktop is simillar to "iron door". 3.bottom of the desk: it doesn't display straight. All the objects combined with terrain. I displayed the .x file in orthogonal projection, it's ok. Now I display in prespective projection, then the problem occurs. How can I fix the problem in prespective mode? Thanks.

Share this post


Link to post
Share on other sites
Advertisement
All 3 artifacts are z-fighting. This is an issue with the z-buffer not being accurate enough, resulting in artifacts when 2 things have very near z-values.

Try using a 24 or 32 bit z-buffer, if you're using a 16 bit one now.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!