Jump to content
  • Advertisement
Sign in to follow this  
Antrim

weird compile errors with Cygwin...

This topic is 4857 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

The code base for the project I'm on has no problems at all compiling on a Linux machine. However, I'm trying to get it to compile under Cygwin at home and I'm getting errors: error: 'glDeleteBuffers' undeclared (first use of this function) error: 'glGenBuffers' " " " error: 'GL_ARRAY_BUFFER' "" "" "" error: 'glBindBuffer' "" "" "" error: 'GL_ARRAY_BUFFER' "" "" "" error: 'GL_STATIC_DRAW' "" "" "" I've searched around and I can't find any info on these errors. The 'undeclared' makes me think that something in my headers is outdated, but I installed all the latest gl related packages for cygwin just a couple days ago. As for my setup, I have the standard default gl stuff from windows on my machine, and I setup Cygwin with gcc and all the gl products that were applicable. If anyone has any good info on what I could be doing wrong, I'd really appreciate the help. Thanks Antrim

Share this post


Link to post
Share on other sites
Advertisement
You need to use glew (or something similar) to use extentions. I guess the linux version of OpenGL has up to date headers, but on Windows we have to make do with the best Microsoft can be bothered to do (which for OpenGL ain't much).

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!