Sign in to follow this  
cskelton

using DevIL in VS .NET 2003

Recommended Posts

Simian Man    1022
The same way as asny library:

Header files:

  1. Open VS

  2. Click Tools

  3. Click Options

  4. Projects tab

  5. VC++ Directories

  6. Under "Show directories for" choose Include files

  7. Add whatever directory you downloaded the headers to



Library files (.lib):

  1. Open VS

  2. Click Tools

  3. Click Options

  4. Projects tab

  5. VC++ Directories

  6. Under "Show directories for" choose Libraryfiles

  7. Add whatever directory you downloaded the lib files to



DLL files:

  1. Just copy all the dlls to C:/Window/system32

Share this post


Link to post
Share on other sites
cskelton    122
I did that...but I keep getting these errors:

loadImage error LNK2019: unresolved external symbol __imp__ilBindImage@4 referenced in function "void __cdecl display(void)" (?display@@YAXXZ)

loadImage error LNK2019: unresolved external symbol __imp__ilGenImages@8 referenced in function "void __cdecl display(void)" (?display@@YAXXZ)

loadImage error LNK2019: unresolved external symbol __imp__ilInit@0 referenced in function _main

loadImage error LNK2019: unresolved external symbol __imp__ilLoadImage@4 referenced in function "void __cdecl display(void)" (?display@@YAXXZ)

loadImage error LNK2019: unresolved external symbol __imp__ilutGLBindTexImage@0 referenced in function "void __cdecl display(void)" (?display@@YAXXZ)

loadImage error LNK2019: unresolved external symbol __imp__ilutRenderer@4 referenced in function "void __cdecl display(void)" (?display@@YAXXZ)

loadImage fatal error LNK1120: 6 unresolved externals

I know I'm probably making myself look real stupid right now, but I have no idea how to fix these errors...any ideas?

Share this post


Link to post
Share on other sites
Simian Man    1022
Did you link your project against the libraries?
To do so:

  1. Click Project

  2. Click Properties

  3. Click the Linker tab on the right

  4. Click Input

  5. Under additional dependencies, list the names of the .lib files seperated by spaces



I don't know why they make it so much more complicated than in Version 6.

Share this post


Link to post
Share on other sites
cskelton    122
Tell me about it. But if they made things simple, they couldn't charge as much for user conferences, among other things. It compiles, so that must have been it. Having other problems, but they're coding related. Thanks for helping stupid ol' me.

Share this post


Link to post
Share on other sites
DrewGreen    370
Quote:
Original post by cskelton
But if they made things simple, they couldn't charge as much for user conferences, among other things.


Roffle, A true cynic :)

Just checking as I'm not sure - Is there a config.h in the same place as ilut.h? (Vc7\include\IL\)? It's part of DevIL

Which version are you using? 1.6.7? Have you tried 1.6.5?

Share this post


Link to post
Share on other sites
cskelton    122
I fixed it....somehow the directory paths for the include and library files somehow got reset, so it wasn't seeing anything. So it compiles now just fine....it just crashes when I try to run NeHe's Lesson 6(DevIL version). It's not that complicated a tutorial, so I have no idea what's up. I'm sure some of my settings are just screwy, but I've looked around and everything seems to be in place. Thanks for all the help to date, and any more help to come.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this