Sign in to follow this  

Possible bug in a defined constant?

This topic is 4380 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

On line 656 of angelscript.h, there is: const char * const asALL_MODULES = (const char * const)-1; However, I noticed in your posts, you use 0 to represent 'all modules' if I was reading that correctly. If I use that asALL_MODULES in functions such as GetFunctionIDByDecl, Build, and AddScriptSection, my program crashes, but if I use 0, it works fine. Is this a bug or am I just not using that define correctly? If I'm not using that define correctly, what is it for then? Thanks!

Share this post


Link to post
Share on other sites
Actually 0 is the module with the name "".

asALL_MODULES can only be used with SetModuleAccess(). In which case it means that the access configuration will be the default for all modules unless specified specifically by the individual module.

Regards,
Andreas

Share this post


Link to post
Share on other sites

This topic is 4380 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this