Jump to content
  • Advertisement
Sign in to follow this  
Mizipzor

Problem with my sprite system

This topic is 4559 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I had problems before with my rotozoomer where nothing was on the surface I rotated to. The problem was that the surface I tried to blit to wasnt properly set up. Now when that was solved some other problems came up. Where I try to draw all the rotated frames in a sprite as debug they are all like... one pixel off. Hard to explain. And when I try to draw the sprite itself... its just black where the sprite should be. :S Even though the frames themselves seems properly loaded as they show up when i debug-draw them (right after theyre loaded). The source for the project can be found here. The sdlwrapper should work fine, Ive used it in other projects. I think the problems here are the loadsprite function in the sprite file. As thats the only thing Ive really done any changes to since when it last worked. I know its quite rude to just "heres my source, please debug" but Im utterly stuck here. If someone got any spare time, could you just lock at the source and put the finger on something that looks suspicious... so I just can get going again. Any help appriciated. :)

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!