Jump to content
  • Advertisement
Sign in to follow this  
Boder

OpenGL Line Artifacts

This topic is 4728 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I've seen many of these line artifacts in some demos and libraries. Picture below. Image Hosted by ImageShack.us This only happens with OpenGL and it seems to only affect people with newer NVIDIA cards. I have a 6600GT with latest drivers. Some examples are (Lava Rock), (Rinth Island), and lately when I have been testing the Photon Library. Maybe there is some easy way to fix it, some driver setting maybe or some call in OpenGL?

Share this post


Link to post
Share on other sites
Advertisement
Well I dug into the problem myself. And I thought I would share.

I started out with these lines (and more, but I've removed the unnecessary).
    // Set smooth shading.
glShadeModel(GL_SMOOTH);

//setup hints
glHint(GL_PERSPECTIVE_CORRECTION_HINT,GL_NICEST);

glEnable(GL_POLYGON_SMOOTH);


I commented out the first line. Nope. I commented out the second. Nope. And the third? Yep! That solved it. Gouraud shading?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!