Jump to content
  • Advertisement
Sign in to follow this  
Enselic

Grammatically correct: ProjectileManager or ProjectilesManager?

This topic is 4513 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

This really is driving me insane; what name does a class that manages projectiles have, is it singular: ProjectileManager or is it plural: ProjectilesManager? It is for the C#/MDX game I've been working on the last 7 months and which I intend to release the source to When It's Donetm. I really am going mental anytime soon... So once and for all, what is the correct name? Thanks. EDIT: Gramaticly Grammatically [Edited by - Enselic on January 11, 2006 1:58:13 PM]

Share this post


Link to post
Share on other sites
Advertisement
Lol, this reminds me of a development job I had a few years ago. It involved the use of a SQL database together with accessing code. The table in the DB containing all entities (for example) would be called "ENTITY" while the code object representing this table would be given the name "Entities" and the object used to compile a group of entities would be called "EntityCompiler"!

More than once this was the source of arguments with some people wanting to change "ENTITY" to "ENTITIES" or something...

Luckily someone usually fought them back with a pointed stick and got everyone back to the task of actually doing something productive!

(But anyway, using good grammer when naming classes is always worth it IMO as then everyone can usually correctly guess the name of the various classes without having to memorise which classes break the rules.)

Mike.

Share this post


Link to post
Share on other sites
Usually prefer the singular rather then plural I think. At least that's what I was taught in college and university.

(edited for spelling)

[Edited by - paulecoyote on January 11, 2006 6:36:15 PM]

Share this post


Link to post
Share on other sites
Well, then it's as good as official!

For managers, the classes should be named <Singular>Manager. E.g. TextureManager, SoundManager, ProjectileManager.

Praise unambiguity!

Share this post


Link to post
Share on other sites
I should think, if you are interested in naming your classes informatively, "ProjectileManager" if an instance only manages one projectile at a time, and "ProjectilesManager" in any other case.

Share this post


Link to post
Share on other sites
I agree with the ProjectileMgr people..

The word Manager implies it manages more than one object,
which happens to be of the type 'projectile'.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!