Sign in to follow this  

avi videos on 3d models

This topic is 4354 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I want to render a video as a texture on a 3d Model. In this Scene there have to be several videos mapped on models. Getting the texture of a video i use the RenderToTexture Event from AudioAndVideoPlayback.dll. When i display this texture on a 3d model, which is drawn in the OnPaint method as fast as it can, the animation is not fluent and the texture is mixed with the current surface. So the texture, which has only to be the video is whole Scene with all models. Then i tried to seperate the videos and the models: The videos uses own devices, where the texture is made. Then they should give the texture to the main device, where the models have to be. But i recognized, that textures are bind to a device and could not used in another device. When i use the TextureLoader, the application gets slow and needs circa one second per frame . The reason is, that saving the texture needs a lot of time. Have you a solution to combine several videos with a directX application? Please help me! [Edited by - Cathan on January 12, 2006 6:18:25 AM]

Share this post


Link to post
Share on other sites

This topic is 4354 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this