Sign in to follow this  

DInput linkage error

This topic is 4356 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have downloaded the DirectX SDK December 2005. With a previous version (i think about 2 years old) but still DirectX 9 I could compile my project. But now with this new SDK an error appears when I try to complile the file. ( it's a german version of Visual Studio 6.0, but the error number is still the same ) ( this message appears, when i link to dxguid.lib and dinput8.lib ) dxguid.lib(dxguid.obj) : fatal error LNK1103: Debug-Informationen beschaedigt; Modul muss neu kompiliert werden. ( this message appears, when i link to dinput8.lib ) dinput8.lib(dilib2.obj) : fatal error LNK1103: Debug-Informationen beschaedigt; Modul muss neu kompiliert werden. the samples of the DirectX SDK are for Visual Studio 2003 and Visual Studio 2005 does the libraries and headers doesnt work on Visual Studio 6.0? I thought the libraries and headers are for C++, and it doesnt matter which development environment you use. please help me!!!

Share this post


Link to post
Share on other sites
As sicrane said - VC6 is a piece of history now, it's 8 years old now [grin]

Go grab yourself a free copy of Visual C++ 2005 Express Edition. It's not as fully-featured as the standard/pro versions, but it'll handle DirectX development just fine. There are so many reasons why you'll appreciate having some decent technology to work with...

Jack

Share this post


Link to post
Share on other sites
Thank you very much.

Where can i get a copy of "Visual C++ 2005 Express Edition".
I searched it at microsoft.com, but i didn't found it.

Share this post


Link to post
Share on other sites
now i found the Visual Studio 2005 Express Edition. thank you for the link.
but can i install visual c++ 2005 Express Edition,
visual basic 2005 Express Edition and visual c# 2005 Express Edition
all together. I have Visual Studio 6.0 and there is c++, java and some more.
Does the installation works without any conflicts?
And is this version totaly free and without any time limits for use?

Share this post


Link to post
Share on other sites
You can install multiple express editions side by side without problems. As long as you download and install them before next Novemember you can use them for free for as long as you want.

Share this post


Link to post
Share on other sites

This topic is 4356 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this