Sign in to follow this  

InitiateSystemShutdown

This topic is 4339 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I'm making a windows service. When a specific TCP dgram arrives, the service should shutdown the PC. It's a TCP server wich waiting for a connection. Two problems : 1/ When the PC has just started (nobody has logged), the service seems to be inactive ! I can not connect to him (connection refused). 2/ After loging AND logout, the service has started (I can connect) but I still cannot call InitiateSystemShutdown function... ! It returns systematicaly : "The device is not ready" !!!!! can anyone help me ? thanks :)

Share this post


Link to post
Share on other sites
Well, fo #1 all I can say with the information you've given is make sure it's a system service installed by the administrator. For #2, I think it's really a problem with your method. How about some source code?

Share this post


Link to post
Share on other sites

This topic is 4339 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this