Jump to content
  • Advertisement
Sign in to follow this  
caseyd

[java] Active Desktop & Applets

This topic is 4624 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I've been searching around for about an hour now but can't seem to find an answer to this. I am trying to test out a simple applet embedded in an HTML file applied to the desktop in WinXP. The html on the page loads fine but instead of seeing the applet, all I am getting is a grey box where it should be. Explorer runs the applet fine and I have the "download applets" box marked in the Active desktop properties page. Any ideas?

Share this post


Link to post
Share on other sites
Advertisement
Hm. I just tried it with an applet I downloaded off the web and that one loads fine. So what is it about my applet that is causing it not to work??

Share this post


Link to post
Share on other sites
Have you tried loading it in the browser from a local file? Maybe it's a security restriction on reading files from the local filesystem.

I'm not sure, but I wonder whether maybe applets loaded from the local filesystem can't load files at all.

Another possibility is that the applet assumes it's being loaded over http and composes URLs accordingly to load resources from - obviously that will fail locally.

Look at the Java console.

Mark

Share this post


Link to post
Share on other sites
Sorry I haven't responded back real quick. I have yet to determine what the problem is. I have another applet running from the same page I am displaying on my Active desktop that runs fine. I did check to see if I can load the file in the browser (both IE 6.* and Firefox), and in IE it wouldn't let the applet run. If I access it via the web (I'm running an apache webserver at the moment with the file stored locally), it ran fine. I changed the security settings in IE to the lowest possible and played with other script settings etc. Still no luck. I have IE setup at the moment so that it will let the applet run whether it is loaded directly from the file system or through the web.

Also, in the page I am loading on the active desktop, the other applet, which is a
random one I downloaded from the web, runs fine and did run fine beforehand. I'm at a loss. I can't think of anything else at the moment.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!