Sign in to follow this  

Bump Mapping Problem

This topic is 4336 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Basically, I'm having this huge problem trying to get dot product 3 bump mapping to work. All I've done was copy the code from the example at http://directx4vb.vbgamer.com/DirectX4VB/Tutorials/DirectX8/GR_Dot3Bump.asp and pasted it into my engine (of course with the appropriate adjustments), but when I render the scene, all I can see are the bump map textures, and not the actual original texture. I think this is because in the example, the vertex format of the face is D3DLVERTEX2, whereas in my engine, I'm just trying to apply the 2 textures (normal and bump mapped) straight to a mesh (D3DXMesh), but the vertex format is not compatible? Any ides of how I could fix this? (Assuming I'm correct) Also, I did try blending the textures using multi-pass blending, but again, there were huge problems. (Lots of meshes were transparent, the colours were slight off, and there alpha holes in lots of the textures). Any suggestions? Thanks, luke88 [Edited by - luke88 on January 28, 2006 11:50:53 AM]

Share this post


Link to post
Share on other sites

This topic is 4336 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this