Sign in to follow this  

Problems with NeHe Tutorials

This topic is 4308 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

HI! I have problem with Your Tutorials. I am working on Borland C++ Builder 6. When I try to compile Lesson 6 (all Lessons before that works well), my PC freezes. I have worked with all tutorials (Lesson 1 - 38) long time ago (about 3 years), and they worked fine. The only difference is that back than I worked on: Intel Pentium IV - 1,8GHz 512MB RAM Geforce MX440 ... OS: WinXP without SP and now I am working on: Athlon64 3000+ 1GB RAM ATI Radeon 9600XT ... OS: WinXP with SP2 What can be a problem? Please help.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Wow now we got noobs who can't even cut and paste without help.

Share this post


Link to post
Share on other sites
Lets work through this one step by step..

If the only difference were those computer specs, then you have solved your own problem.. but ..

The NeHe Tuts are plane text files CPP and Headers
The Compiler takes the files and inspects them and performs it's voodoo magic to produce an Executable. Compilers are smart things, perhaps even Borland Builder 6. So the problem being the code crashing the computer is not likely the problem.

Perhaps libraries you have installed are bad?
Perhaps you have a dodgy copy of Borland C++ Builder 6.

I remember in VS6 I could crash the IDE some times by pressing F7 (build) twice quickly :) But never the computer..

Aside from compilers being smart Modern OS's, such as the one you are using are quite smart also.. I've have not yet locked up XP SP2, perhaps I'm lucky.

Does other code compile OK?

Solutions
- Get a good copy of your compiler
- Get a good computer, yours is not good enough.. You need at least a DUAL CPU system and 2GB of ram to use Borland C++, because of it's Mandatory Hyper threading in the Inter-predictive type safety of the State machine reciprocals.

Or switch your build settings to Jazz mode.

I should go now.

Share this post


Link to post
Share on other sites

This topic is 4308 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this