Sign in to follow this  

[MDX] Some serious results when applying texturestates to an object?

This topic is 4307 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

DxDevice.TextureState[1].ColorOperation = TextureOperation.SelectArg1;
DxDevice.TextureState[1].ColorArgument1 = TextureArgument.Constant;
DxDevice.TextureState[1].ConstantColor = Color.Blue;
When just applying this texture states to an object, the object is rendered with some serious trash-like colours... See: http://web48.isp4net.de/other/trash.jpg When rendering the scene new, these colors move around in the object...and in the debug-mode of DX the program just crashs..

Share this post


Link to post
Share on other sites
Did you disable stage 2? Stages must terminate with a disable op.

Did you set an alpha op for stage 1? It is invalid to specify only color or alpha on a stage. Both must be given.

Does your card support per stage constant? (D3DPMISCCAPS_PERSTAGECONSTANT)

I'm assuming there is a stage 0 set. What does it do, since you're overwriting it's color output in stage 1 anyway?

Share this post


Link to post
Share on other sites

This topic is 4307 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this