Sign in to follow this  
euclid

How to MAKE liballeg.a ?

Recommended Posts

euclid    116
Hi, this is my second thread, and I have a problem with make the Allegro lib. At first, My OS is winxp; I can use DJGPP, and set the right evironment variable - "g:\DJGPP\DJGPP.ENV" & PATH - "g:\DJGPP\bin"; 'make.exe, gcc.exe ...' are in 'djgpp/bin/'. But when I run 'make install' or 'make makefile.all' under cmd mode, it has many trouble at "gcc -DALLEGRO_SRC -Wall -Wno-unused -mcpu=pentium -O2 -funroll-loops -ffast-math -fomit-frame-pointer -I. -I./include -oobj/djgpp/alleg/fli.o -c src/fli.c", "src/fli.c: In function '_fli_parse_chunk':" and "src/fli.c:697: error: invalid lvalue in increment". I think that the function name is too long. Help! If anyone have a COMPILED liballeg.a, please send me via email: euclidwang@163.com | euclidwang@gmail.com GOD bless you~

Share this post


Link to post
Share on other sites
DHunter    126
Hi!

From your log, I can't determine where exactly is the error. However:

- which version of gcc are you using? Allegro won't compile with 3.0.0 and 3.0.1
- you need to run 'fix.bat djgpp' before running 'make'(though it seems you've already done that)

Second, although Allegro was originally made using djgpp, djgpp is not meant for WinXP, and as the documentation states, you're likely to experience errors using djgpp and allegro on winxp.

I would heartly recomment MingW32. It is also based on gcc, but is made for Windows, and has a much less restrictive licence(it has it's own standard library implementation, which is not under gpl). It works excellent, has a growing number of dedicated tools, and works really well. It compiles Allegro without any problems.


I've been using Allegro for a long time, so if you will still have problems, feel free to contact me personally at: ivan (underscore) galic (at) vip.hr


Hope this helps,
-Ivan

Share this post


Link to post
Share on other sites
euclid    116
Thank you all!
I had made a 'liballeg.a' using 'ar' myself. But when linking, it shows "Error: g:/djgpp/bin/ld.exe: cannot find -lliballeg.a", I had put the 'liballeg.a' at that...

I will try Mingw then~

Share this post


Link to post
Share on other sites
DHunter    126
The link error is because you gave 'liballeg' to the linker. Instead, you need to give -lalleg as the option. The same is with mingw.

-Ivan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this