Sign in to follow this  
jchmack

my game works only on computers with visual studio 2005

Recommended Posts

jchmack    187
Im using VC8 and im trying to distribute my game. When i give it to them though i get this error: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. It only works on computers with visual studio 2005. what do i do?

Share this post


Link to post
Share on other sites
Guest Anonymous Poster   
Guest Anonymous Poster
when you compile your program make sure you have it set to release and not debug.

Share this post


Link to post
Share on other sites
jchmack    187
ok i added the dll's in my directory like it said:

* C:\Test\game3.exe
* C:\Test\MSVCR80.dll
* C:\Test\MSVCP80.dll
* C:\Test\MSVCM80.dll
* C:\Test\Microsoft.VC80.CRT.Manifest

but i still get the same error...

Share this post


Link to post
Share on other sites
jchmack    187
i read an article saying that i should run this:

C:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\BootStrapper\Packages\vcredist_x86

but i still get the same error.

I just run that on the target computer and then my app should work right?

Share this post


Link to post
Share on other sites
vNistelrooy    140
Quote:
Original post by jchmack
i read an article saying that i should run this:

C:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\BootStrapper\Packages\vcredist_x86

but i still get the same error.

I just run that on the target computer and then my app should work right?


If you have built under the release configuration.

Share this post


Link to post
Share on other sites
Sam Gamgee    222
Simple way to fix this should be to:

load up your project settings, and go to C/C++ -> Code Generation
Next change runtime library from Multi-threaded DLL to Multi-threaded and rebuild. That should sove your problem

Share this post


Link to post
Share on other sites
jchmack    187
Quote:
Original post by Sam Gamgee
Simple way to fix this should be to:

load up your project settings, and go to C/C++ -> Code Generation
Next change runtime library from Multi-threaded DLL to Multi-threaded and rebuild. That should sove your problem


well i tried this and i get a bunch of link errors:

edit i took them out because they took too much space

Share this post


Link to post
Share on other sites
jchmack    187
Quote:
Original post by vNistelrooy
Quote:
Original post by jchmack
i read an article saying that i should run this:

C:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\BootStrapper\Packages\vcredist_x86

but i still get the same error.

I just run that on the target computer and then my app should work right?


If you have built under the release configuration.


how do i build unde release config

Share this post


Link to post
Share on other sites
gumpy    795
Quote:
Original post by Sam Gamgee
Simple way to fix this should be to:

load up your project settings, and go to C/C++ -> Code Generation
Next change runtime library from Multi-threaded DLL to Multi-threaded and rebuild. That should sove your problem


static linking usually does the trick, but static linking isn't an option when using certain libraries such as sdl. here is the solution i use. it lets you create your own runtime installer to distribute with your app.

edit: this is for vc express. i think all of the other versions com with the runtimes installer.

Share this post


Link to post
Share on other sites
jchmack    187
Quote:
Original post by gumpy macdrunken
Quote:
Original post by Sam Gamgee
Simple way to fix this should be to:

load up your project settings, and go to C/C++ -> Code Generation
Next change runtime library from Multi-threaded DLL to Multi-threaded and rebuild. That should sove your problem


static linking usually does the trick, but static linking isn't an option when using certain libraries such as sdl. here is the solution i use. it lets you create your own runtime installer to distribute with your app.

edit: this is for vc express. i think all of the other versions com with the runtimes installer.


ya i have the full version and im trying to use the built in merge modules

im trying to create a setup and deployment project to create an install for my app

it creates the msi/exe files fine BUT:

when i run them i get this error:

"the folder path 'julius/ryan abella' contains an invalid character

this is the licensed to information that can be found in

help-> about microsoft visual studio

in the top right.

how can i change this info to be so that it doesnt complain about the '/' which is what i think is causing the problem

Share this post


Link to post
Share on other sites
jchmack    187
ok ive tried everything:

i have renamed every key in the registry that contained the bad name
i have rebuilt the .msi and setup files

and i still get the same error

AAAAAAAAAAAAAH!!!!!!

Share this post


Link to post
Share on other sites
Calin    419
If you can't get the runtime installer working use the gumpy macdrunken solution. It should solve your problem. I have the Express version and I use a runtime installer made after those instructions.

Share this post


Link to post
Share on other sites
jchmack    187
omg i got passed the invalid character thing. even though i had changed the string in registry it saved it somewhere in the project so i had to make a new one from scratch. But now im getting this error:

http://www.ogre3d.org/phpBB2/viewtopic.php?t=18785

sorry bout the cross forum post but i think the problem may have more to do with ogre3d than anything else.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this