Jump to content
  • Advertisement
Sign in to follow this  
geekalert

correct method? [SOLVED]

This topic is 4528 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

is this the right way to use wrapping?
MLBlock NextTag() { return (elems[(block_ptr > elems.size()) ? (block_ptr = 0) : (block_ptr++)]); };

MLBlock PrevTag() { return (elems[(block_ptr < 0) ? (block_ptr = elems.size()) : (block_ptr--)]); };


elems is an std::vector.

Share this post


Link to post
Share on other sites
Advertisement
Remember that elems[elems.size()] is invalid.

Also, your NextTag/PrevTag functions seem to be misnamed - they both in general return elems[block_ptr], changing block_ptr. Is this what you wanted?

Share this post


Link to post
Share on other sites
Quote:
Original post by bakery2k1
Remember that elems[elems.size()] is invalid.

Also, your NextTag/PrevTag functions seem to be misnamed - they both in general return elems[block_ptr], changing block_ptr. Is this what you wanted?


Thanks for the help! And yes that is what i wanted...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!